Logitech Setpoint missing mouse and keyboard tabs fixed

Be sure to check the comments. Your particular setup may be covered there.

*

Thanks to feedback from Jonathan On December 10, 2016:

Your trick worked for me, but then I found a newer software called Logitech SetPoint Options (https://support.logitech.com/en_us/software/options) which worked as advertised for me. You might consider adding a mention to the top of the post to save lots of people lots of trouble.

*

August 25, 2016: And, for those of you (myself included) wrestling with the Logitech double click problem, I solved mine with Scotch® Brand tape. View the simple fix video here. It seems that those stupid sons of bitches at Logitech engineering can’t even design a push-button that functions for a reasonable amount of time.

I added one layer of Scotch tape at a time, rather than use drywall tape. It’s such a simple fix that I decided to go that way. We’ll see how it goes.

*

I must admit that I no longer use the Logitech mouse software that those stupid sons of bitches at Logitech distribute. My Logitech mouse works just as well and is just as functional without the software that those stupid sons of bitches at Logitech publish. So long, you Logitch useless sons of bitches that write your software. It’s been good to know ya as a punching bag.

The Windows 10 mouse controls in Settings / Devices / Mouse & touchpad / Additional mouse options (at the bottom of the screen) are more than adequate for the average user. A similar mouse control is contained in all earlier versions of Windows.

*

UPDATED June 21 2015: I’m running a pre-release version of Windows 10. SetPoint appears to be working as it should. Ditto Windows 8.1 with the patch Tuesday updates earlier this month.

*

UPDATED July 2014: Those stupid sons of bitches at Logitec™ have come out with an update to their SetPoint software (6.65.62). But don’t worry, folks. Those stupid sons of bitches at Logitec STILL DON’T HAVE A WORKING VERSION. They’re still in beta. Go figure.

Note to those stupid sons of bitches at Logitec: Why can’t you stupid sons of bitches at Logitec get a version of your SetPoint software that actually WORKS? Why can’t you, you stupid sons of bitches at Logitec, PRODUCE a version of your SetPoint software that works? Furthermore, why can’t you stupid sons of bitches at Logitec hire a Chinese or Japanese kid that could bring your SetPoint software into the 2000s? I mean, really, you stupid sons of bitches at Logitec have had since around 2007 to produce a product that actually works.

Finally, a query: What do the stupid sons of bitches at Logitec do all day in their little cubicles?

*

Logitech has had a problem since at least 2007 with mouse and keyboard tabs disappearing/missing from their Setpoint software. The tabs will randomly disappear after an install. Trust me on this, and don’t bother with the google, because those stupid sons of bitches at Logitech don’t have a meaningful, clued-in response that doesn’t include removing and reinstalling the software. Even then, Logitech can’t get their Setpoint software to run with mouse and keyboard tabs.

Here’s how I solved the problem with Windows 8 (if you’re running Win7, give it a try and let me know if it works):

  1. Open Task Manager with CTRL-SHIFT-ESC and select Processes.
  2. Right click on Logitech KHAL Main Process and Logitech SetPoint Event Manager (UNICODE), select End task to close each of them in turn, and then close the Task Manager.
  3. Go to c:/Program Files/Logitech/SetPointP.
  4. Scroll down to SetPoint.exe.
  5. Right click on it.
  6. Select Run as administrator, and

Voila! Problem solved – for a while, at least, probably until one needs to complete the routine all over again.

Update:

  1. If you create a desktop shortcut to SetPoint.exe like I did, you won’t have to continually drill down into Program Files. All you have to do is right click and select Run as administrator after exiting the SetPoint icon in the Task Manager.
  2. I have discovered that if I select Show hidden icons on the Taskbar, right click on the Logitech icon and select close, then all I have to do is the first bullet point, above. There’s no need to go into the Task Manager at all.

Addendum: Really? Uninstall and re-install and restart the computert? Logitech can’t be serious about that, can they? Because IT DOESN’T WORK!

*

ADDENDUM Mouse wheel stops scrolling – December 27, 2013: I turn my Logitech Anywhere MX mouse off to save juice. When I turned it back on, it wouldn’t scroll. To solve that problem, I turned it off again, removed the batteries, and put them back in. That appeared to fix the scrolling problem.

66 thoughts on “Logitech Setpoint missing mouse and keyboard tabs fixed

  1. I love you sir, for you helped me get past the annoying “keyboard tab is missing” of the crap they distribute as SetPoint.

    Damn those motherfuckers… I whish they used their products at least once before distributing.

  2. Missing the Mouse tab on most computer in the office in Logitech Setpoint. Windows 7 64 bits.

    Be aware that Logitech is working on transferring their old software “Setpoint” to their new software “Options”.

    Logitech “Options” will be required on the computer to be able to use the mouse features. Although see the following:

    If “Options” is installed after “Setpoint”, “Options” will not start by launching the software (base on a test on one computer one time).

    “Setpoint” will required to be uninstalled from the add/remove program (appwiz.cpl). No need to restart.
    Afterward, install “Options”. (See drivers for your hardware on the Logitech website)

    More issues in the office is that we have a huge number of Logitech M510 which lead me to the following:

    If the M510 is an older version part number 810-001724 (orange unify logo under the mouse), the mouse is not compatible with “Options” and it will tell you when launching the software.
    Therefor it is required to install “Setpoint” after “Options” and the Mouse tab will appear within “Setpoint”.

    If the M510 is a more recent version, part number 810-004709, the mouse is compatible with “Options”, you need to run “Options” from the start menu panel. I don’t believe “Setpoint” is required but I’ve installed it anyway.

    Be aware that changing your hardware is immediate. If I remove a M510 P/N 4709 and plug in a P/N 1724, the “Setpoint” is showing me the mouse tab right away (must not have the panel opened during the hardware switch).

    Software used:
    Options_6.00.547.exe
    SetPoint6.67.83_64.exe

      • I’m not sure what I’m suppose to say. I’ve already said what was the solution at the moment. Of course in a couple of months, their new software called “Options” may take over all the M510 regardless of their part number and therefor we will have to move to “Options” and therefor may uninstall “Setpoint”

  3. I started having this problem eversince I updated my Adobe Flash which also messed with my internet connection. I had to remove Adobe Fash and reinstall Logitech Setpoint software (the old one not new updated) and my tabs showed up again, and the mouse works fine. Now I’m having browser problems on websites that require Adobe flash.

    • I no longer use Logitech Setpoint software. I find I don’t need to know how many days I have left on the batteries. When the cursor freezes, I install new batteries. In fact, now that I think about it, I can find no reason whatsoever for Logitech Setpoint software. My wireless mice work just fine without it.

  4. Thank you so much for posting this… solved my problem. I can’t believe how easy it was to find a fix when I searched. I was expecting it to take hours of f***ing around with half-back solutions. As it turns out this problem is so >incredibly common< that a simple search is all that it took. Logitech: pull your head out of your ass.

  5. ROFLMAO! Thanks for the tip, I most ungracefully kaiboshed the said running processes and ran this setpoint MOFO as admin et VOILA! My mouse and keyboard tabs are there!

    Too bad those sons of bitches at Logitech are too busy being sons of bitches to notice that good customers are frustrated and view them as nothing but sons of bitches.

  6. The problem persists in win7x64 w a M500 corded mouse and no Logitech drivers…so maybe you can curse at Microsoft too? This has happened to me a number of times over the years on XP and Win 7 so I think it is a M$ issue…

  7. Thanks man, this worked. Before this I had to reinstall the driver every time this happened. Logitech doesn’t have a solution but good thing I found this.

  8. After struggling with this for quite some time for many of my customers it dawned on me *why am I forcing myself to use Setpoing 6.65?*

    Using older versions of the software- this Logicool download for Setpoint 6.60 worked for several different mice and keyboard. The link is directly to Logitech’s FTP server page
    I used Setpoint6.61.15_64j.exe since we operate 64-bit Windows 7.

    ftp://ftp.logitech.com//pub/techsupport/mouse/

  9. I have a solution!

    I lost keyboard sound control, which led me to realizing I no longer had a keyboard tab on my Setpoint. My keyboard is an illuminated USB K740 . I googled and tried everything multiple times. I wish I had a dollar for every time I uninstalled, rebooted and reinstalled the software. Installed as admin, A/V off, thumb in my ear, no difference. Removed and reinstalled the drivers too many times.

    I finally decided it was a hardware issue and ordered another keyboard, which came in over the weekend.

    Same crap!

    SOLUTION:

    I finally decided it could possibly be driver conflicts. I went to Device Manager and went wild, removing anything and everything possibly related. I hit the solution early. I removed everything under Keyboard. Then I moved to Human Interface Devices. There were 8 HID-Compliant listings, including 2 Logitech. I started at the top (the non-Logitech ones) and started removing them. After about the 3rd, Setpoint popped open with the keyboard tab. The sound keys started working as well.

    I rebooted and let everything reload, and it’s 100% good.

    Hope this helps someone!

    Jackson

  10. My fix was slightly different and SetPoint now works. I’m running Win 8.1 x64 Pro
    1. Open Task Manager with CTRL-SHIFT-ESC and select Processes.
    2. Click on each Logitech process and click the End task button to close each of them in turn, and then close the Task Manager.
    3. Go to c:/Program Files/Logitech/SetPointP.
    4. Scroll down to SetPoint.exe.
    5. Right click on it, select Properties.
    6. Click the Compatibility tab.
    7. Click the Change settings for all users button.
    8. Check the box Run this program as an administrator
    9. Click OK, again click OK
    10. Click the start button > Control Panel > Mouse. In the Mouse Properties window you should see the SetPoint Settings tab,

    11. Click the SetPoint Settings tab and you should then see the SetPoint Settings window

    12. Voila! Problem solved – for a while, at least, probably until one needs to complete the routine all over again.

  11. Welp, I need to configure my keyboard–I’d installed setpoint, but but setpoint would provide a tab for my mouse. I closed setpoint, downloaded the “full” installer, and ran it. As the install began, I disconnected my mouse. After the install, replugged the mouse and the software saw both devices. Yay.

    Now I can finally apply a Fn lock, which the K400 laughably does not have.

  12. This worked for me on a Dell Inspiron running Win XP, 32-bit OS:
    After many tries of uninstalling/installing and even trying earlier versions of the SetPoint software, I found that using the unpairing/pairing suggestion offered by
    “Bookum_Danno” got my K400r keyboard/touchpad into a mode where I can configure everything; all tabs (My Mouse, My Keyboard, Tools) are now shown.

    • Here’s Bookum_Danno’s solution, so those interested don’t have to go searching for it farther up:

      Make sure you have the Setpoint (Full) and not (Smart) software.
      1 – You will need a mouse USB OR PS/2.
      2 – Once you Install the Setpoint (Full version). Open the app.
      3 – Click on Unifying Settings Icon. Open Unifying Software.
      4 – Click on Advanced and Highlight your device.
      5 – Click on Un-Pair and turn Off your device and wait a few seconds and turn back on (This is where you need the other mouse).
      6 – Now pair your device and with Setpoint still open, you will see the tabs start to appear.

  13. After spending an hour or two fooling around trying to get the mouse/keyboard tabs for a K400r keyboard on a Win7pro 64 bit machine, I finally got it to work. I *think* the key was to do a full install with a separate corded keyboard and mouse (in admin mode, blah, blah). Then plug your USB dongle in and let the drivers install. I also uninstalled the unifying software before reinstalling setpoint, too, so that might have factored in.

    Wish I could bill Logitech for my time.

  14. I have Windows 7 64-bit with a CORDED, USB Logitech G500 Gaming Laser Mouse.

    Blog owner, you are right on the money when you said these stupid sons of bitches at Logitech just plain don’t know what they are doing!

    I’m an EXTREME master power user, and I have tried everything, and I cannot get this SetPoint to show anything except a stupid, useless Tools tab!

    I tried uninstalling, reinstalling, throwing salt over my shoulder, holding 1 hand on my head while spinning in a circle – all the stupid superstitious hijinks that Logitech support wants you to do. But what we really need is TRUE “ROOT CAUSE ANALYSIS”!!!!

    I think this has something to do with the 1 or both of these 2 things:

    1. The fact that Microsoft IntelliPoint had an update and offered it on Windows Update to all Windows 7 users, something about Microsoft USB HID Driver Update or something like that. I know I have seen new Microsoft USB Keyboard Driver and USB Mouse Driver offered repeatedly.

    2. The multiple “USB Input Device” listed in Device Manager. There is a complicated chain going from a “USB Composite Device” and several children beneath it until you finally reach the actual Logitech Mouse you are trying to control. I think Logitech is failing somewhere high in this chain and thus the SetPoint software is never seeing the Logitech device, because whoever wrote it designed it such that even though under my Devices and Printers, it correctly says Logitech G500 Mouse, and even shows a damn PHOTO OF MY EXACT MOUSE!! — Somehow this SetPoint software STILL cannot manage to recognize the existence of my mouse and therefore only shows the useless Tools tab.

    • The thing is, given how many Logitech devices are out in the world, imagine how many people are having this exact same problem. Not only that, but try and picture all of the computer illiterate that aren’t even aware the problem exists, and continue to use the product, notwithstanding that they don’t know they have the problem – if you’ll pardon my fractured reasoning.

      Given the length of time that Logitech has allowed this problem to continue unsolved, it’s unforgivable that both Logitech AND Microsoft don’t have a working group attempting to resolve Logitech’s disappearing mouse and keyboard tabs.

  15. on this website i was informed about logitech setpoint and how to get an update when on the logitech site they said i did not need any further software. on going to program files/logitech/setpoint.exe, i was able to update setpoint with out any problem. logitech through setpoint.exe stated there was an update for my logitech elite keyboard and downloaded.installed accordingly. so thanks to the person for the information.

  16. I have an HP Elitebook with Windows 7 – 64.
    My new external interface is a Logitech tk820 trackpad-keyboard combo.

    Setpoint does not show a mouse, keyboard or any other tab except “Tools” which does nothing at all useful.
    If I launch the unifying software, it sees the tk820. I can pair and unpair all day, and no tabs appear in Setpoint, so I can’t configure the thing.
    I’ve killed both Logitech processes, then restarted as Administrator, several times. No change.
    So, your advice doesn’t seem to work for me on Windows 7.

    Everything thinks it’s up-to-date.

    F**K you, Logitech!

    They’ve got to be a bunch of a$$hole$ not to have fixed this in nearly 7 years. The tk820 is not an ancient product. There’s just no excuse.

    I’m going back to my Amazon Review and updating with this info, because it’s the only way to hurt such shameless f**ks. I don’t know why they’d go to the trouble to make nice hardware when they can’t be bothered even trying to make the accompanying software work correctly.

    My corporate IT department got me onto the tk820 (which I’ve bought for my own use when I bring the laptop home), because they wanted to trial it, in advance of rolling out a thousand-or-so in the company. As a combo, it frees-up a needed USB port on corporate laptops. I’m one of the early Guinea Pigs, so I’m going to badmouth this product and Logitech to the IT guys.
    A hundred grand here, a hundred grand there, and maybe Logitech will wake up when it starts to add up to some serious pocket-change.

    I’ll also keep my eyes open for a similar Microsoft combo device, so I can put the tk820 on Kijiji…. (but only after I find a decent replacement) 🙂

    • I’m sorry to hear that the Win8/8.1 solution won’t work for you in Win7. It is unfortunate.

      This problem with Logitech products has been going on for years and years. It’s not new. Logitech as a company doesn’t appear to be all that interested in solving the problem. We all certainly know that to be true when their “solution” to the problem is to “uninstall and then re-install and /or re-boot” somewhere in between, or whatever the hell it is they’re telling us.

      Dear Logitech: IT DOESN’T WORK.

  17. Solution:
    Make sure you have the Setpoint (Full) and not (Smart) software.
    1 – You will need a mouse USB OR PS/2.
    2 – Once you Install the Setpoint (Full version). Open the app.
    3 – Click on Unifying Settings Icon. Open Unifying Software.
    4 – Click on Advanced and Highlight your device.
    5 – Click on Un-Pair and turn Off your device and wait a few seconds and turn back on (This is where you need the other mouse).
    6 – Now pair your device and with Setpoint still open, you will see the tabs start to appear.

  18. FWIW — Win7 Ent x64, IE 10 — I was able to use this same technique to resolve an issue where Setpoint advance mouse commands (forward, back, minimize, programmed keystrokes, etc) stopped being recognized in IE. Ironically, they’d work on any other window… just not my browser sessions. Once I killed the app and re-launched manually as admin, functionality returned. Thanks for the insight!

    • Thanks for coming by to tell us about the added benefit. Just a reminder for everyone: You can make a desktop shortcut to setpoint.exe and Run as administrator as required after exiting.

      • I have had a MX550 (Wave keyboard & 510 mouse) for several yrs, which I love, broke the keyboard this morning (don’t ask) and purchased a new one today at Sams Club.

        Windows 7 64-bit . . same exact system that worked with it yesterday and for the last 2 yrs.

        I cannot get the tabs to show up in Setpoint for the mouse or keyboard. I’ve tried everything you have recommended. twice? 3 times? Nada. Nothing but the tools . .

        Help?

        • Sorry, but beyond what works for me and others as outlined here, I have no clues about Logitec’s software and why it doesn’t work as Logitec advertises.

        • 1. If you haven’t yet, restart your computer. I know I sound like a jerk but seriously, that’s all I needed.

          2. Make sure you kill ALL of the KHAL processes. Then try again.

          3. If all else fails, kill all of the Logitech/KHAL processes. Then try going to C:\Program Files and right-click the Logitech folder and click properties. Go to the Security tab. Click Edit (you’ll need to be an administrator). Select Users. Click the check box under Allow and next to Modify. Click OK and then OK again. Restart your computer and try again. Please let everyone know if this step works. I didn’t have to go this far so I haven’t a clue. It’s just the next logical step I’d take.

          • Re-booting my Win8 machine will only bring up the Tools tab. I use point #2 under Update to get running with all necessary tabs. So far, all runs well until a re-boot.

            • Sorry RF, I meant that as a possible troubleshoot for DH.

              As a caveat, my step 3 can be undone with the same steps but unchecking the modify block instead. I was just thinking this whole issue sounds like a conflict of either rights or processes and I can’t figure out a processes conflict without disassembling them.

              RF: Can you just disable your KHALs in the startup tab of msconfig? That should make it permanent for you.

  19. I’m having the same problem. I’m running XP on a Dell desktop and recently bought an M510 mouse. My old SetPoint (4.80 maybe?) wouldn’t recognize it, so I’ve been trying to install 6.52 with no luck. The system recognizes the mouse, but I can’t (e.g.) reprogram the buttons.

    So far, not only am I still dealing with Logitech tech support, I’ve tried pretty much everything suggested above as well as trying to uninstall and then reinstall in safe mode. Still no device tabs.

    Any advice would be appreciated!

  20. Setpoint runs as admin by default, look at the shortcut properties as soon as you make the shortcut and you will see this.

    • Setpoint may very well run as you describe. Unfortunately, it still does not run properly on boot, necessitating an exit and a Run as administrator on my system after a Win8 boot to have it put the tabs on the interface. Setpoint still stops working occasionally, requiring an exit and a Run as administrator from my desktop shortcut.

  21. Doesn’t work on Windows 7. I got an EX-110 keyboard with a M185 mouse and it only appears tab for mouse cause the mouse is new.

  22. My solution on this (I use Win8 64bits):
    – Kill all Logitech related processes
    – STOP and START Logitech Bluetooth service
    – (As my dongle is not up to date and CANNOT be updated… I get the messge asking me to update – I just press ignore)
    – Restart SetPoint (Normal, no need for admin)
    – My device are back!

  23. Solution (in my case):

    Download drivers appropriate for your system (not the smart installer, the full installer)
    Disconnect internet (take out wire… disable connection… whatever way makes you happy)
    Shut off all firewall and virus scanner (in my case, Webroot SecureAnywhere is the culprit)
    uninstall any previous driver install attempts
    Reinstall from full installer
    Open SetPoint (yay! My Mouse is there!)
    Re-enable virus software
    reconnect internet
    Enjoy mousing.

    Doing this resolved the issue for me completely. The trick is to have the virus / system protection off when you do the installation. After that it can be on and the driver works fine. I think it’s just that the system protection interferes with what the driver installer is trying to do during the install process. After that, it’s fine.

    Hope that helps someone

  24. thank you. I now understand what was going on – Logitech was configuring setpoint depending on which device it recognized. When I connected a mouse with higher functionality the software/driver adapted itself to that mouse, and the tab became visible and operational. That functionality disappeared when i reconnected the mouse that was supplied with the tablet so it is clearly not configurable at all. thanks for your help.

  25. You must access the Setpoint mouse/keyboard panel tabs from “Show hidden icons” in the task bar. If you try to access either from the Control Panel, all you’ll get is Windows 8 default controls, which do not show the Setpoint control tabs.

    Left-click on “Show hidden icons”. Left-click on the green keyboard/gray mouse Setpoint icon. Select “Mouse and keyboard settings”.

    Let me know how it goes.

    • Just tried that, and am still getting the same setpoint settings window which only has one tab – tools – at the top. Along the side are info, tools, bluetooth and unifying sub-tabs. Am I doing something wrong? Appreciate your help. Thanks.

      • You must have the Logitech mouse and keyboard software installed for your particular combination of mouse / keyboard.

        In Show hidden icons, right-click over the Logitech icon and select “Exit”. Then run “Setpoint.exe” as an Administrator.

  26. I followed your steps 1-6 and still cannot access the keyboard or mouse tabs within the setpoint tab of the control panel mouse settings. I’m running Windows 8 on a Dell XPS18, which actually came with a logitech keyboard and mouse, but without the ability to configure mouse buttons at all – let alone for individual programs. Irritatingly, the left/side mouse button does not ‘go back’ nor does the right/side mouse button ‘go forward’. I can go ‘back’ if I left/side-button-click and mouse-wheel-left at the same time. But this hurts my hand. Why can’t this functionality simply be assigned to the left/side button?

    Any suggestions gratefully received.

  27. O.M.G. Thank you so much! I literally spent hours trying to figure out why the setpoint worked fine on my laptop but not on my desktop. This fixed everything. Logitech has no clue. Hopefully this finds countless others who are having this problem.

  28. Awesome article. This workaround actually works, unlike Logitech’s support page.

    Logitech lists the missing tabs as a known problem on their support page and lists a known solution — but their “solution” doesn’t change a thing, and wastes your time.

    Nice post!

    • Microsoft’s Patch Tuesday fixes of February 2013 appear to have assisted in curing the problem somewhat in Win 8 – or at least, may have reduced the occurrence. I’ve had to use my method once since then.

      I’m glad you were able to locate my fix.

Leave a Reply